Openmoko Bug #2333: Intermittent kernel oops when using wifi

Openmoko Public Trac bugs at
Fri Mar 5 09:21:06 CET 2010

#2333: Intermittent kernel oops when using wifi
 Reporter:  bt4              |          Owner:  openmoko-devel
     Type:  defect           |         Status:  in_testing    
 Priority:  normal           |      Milestone:                
Component:  System Software  |        Version:  unspecified   
 Severity:  normal           |       Keywords:  wlan oops     
 Haspatch:  0                |      Blockedby:                
Estimated:                   |    Patchreview:                
 Blocking:                   |   Reproducible:                

Comment(by PaulFertser):

 Are you really sure you used a kernel module with the patch and that dmesg
 output is really identical?

 Please, next time you do any testing,
 1. #define DEBUG at the top of ar6000_drv.c (it might change the timing
 tough, so if you can't reproduce with it, disable it back, i still hope
 it's possible to reproduce it with this option, please try hard).
 2. post dmesg
 3. post kernel module binary you used (preferably the .o, not .ko file) so
 i can locate (instead of guessing) the op that caused NULL pointer

 Also you might speed up the process a lot if you enable me to reproduce
 the issue. Trace all calls to wpa_supplicant and try to reproduce with
 wpa_cli (though it might be hard due to timing issues). Alternatively, i
 can install nwa myself but i'm unsure i can reproduce your network
 conditions so try to minimise the requirements (it's better to have a way
 to reproduce it once in 10 times than having to find "an ap with weak
 signal etc etc).

Ticket URL: <> <>
openmoko trac

More information about the devel mailing list