Build dfu-util for Windows

Tormod Volden lists.tormod at
Thu Nov 10 08:55:09 CET 2011

On Thu, Nov 10, 2011 at 8:10 AM, Satz Klauer <satzklauer at> wrote:
> Hi,
> according to
> I tried to compile dfu-util for Windows. Unfortunately it seems like
> it expects libusb1 while libusb-win32 seems to support API version 1.0
> only.
> So what did I miss here: are there some modifications necessary to let
> dfu-util compile with the current libusb-win32 or do I have to use an
> older version of dfu-util which makes use of libusb0?

Hi Elmi,

As far as I understand, libusb-win32 only supports 0.1 so far, but
libusb itself is getting win32 support in the 1.0.9 version (you can
try a release candidate). See this post for more info:

Hope this helps,

> Elmi

More information about the devel mailing list