netreg registration denied (was: Re: Anyone else got a non-working GSM modem?)

Oliver Heesakkers openmoko at
Thu Aug 2 22:46:39 CEST 2007

Op Thursday 02 August 2007 00:07:13 schreef Cindy Mottershead:
> I have had the best luck initializing the gsmd and making/receiving
> phone calls by issuing the commands over ssh.  The cu program doesn't
> work reliably for me, but the libgsmd-tool does. The gui interface
> hardly ever works.
> I run this in one shell (to watch the debug output):
> gsmd -p /dev/ttySAC0 -s 115200 -F
> and run libgsmd-tool in another to issue the commands. See

When performing above steps with my Orange prepaid sim libgsmd-tool tells me 
that net registration was denied:

My Orange subscription sim on the other hand, can make calls.

I've tried multiple other sims from friends, but there is no connection that I 
can see between working sims (age, networks, local or roaming, prepay or 

I tried disabling the ttySAC0-line in /etc/inittab. This prompted a pin-entry 
box on reboot and makes the icon in the right hand corner show success, but 
results are the same.

Judging from Walter's post "Making phone calls" I have a fair chance of 
getting a working Telfort prepaid-sim, but I'd much rather use this Orange 
prepaid as long as the software isn't mature enough to use my 

Can anyone shed some light on why some sims work and some don't? And more to 
the point: Can any sim be made to work?

Mentioned networks are Dutch.

More information about the device-owners mailing list