MokoMakefile Error

Jeff Rush jeff at
Fri Aug 3 12:50:58 CEST 2007

Andreas Lorensen wrote:
> Wanted setup so I was able to compile own versions of the software. And 
> wanted to start setting up something to start whit using MokoMakefile 
> But after long time I end up whit this error:
> NOTE: package glibc-2.5-r4: task do_package_write: started
> Packaged contents of locale-base-ar-kw.iso-8859-6 into 
> /home/andlo/openmoko/build/tmp/deploy/ipk/armv4t/locale-base-ar-kw.iso-8859-6_2.5-r4_armv4t.ipk
> Packaged contents of locale-base-ar-kw into 
> /home/andlo/openmoko/build/tmp/deploy/ipk/armv4t/locale-base-ar-kw_2.5-r4_armv4t.ipk
> locale-base-aa-er
> *** Error: Package name  contains illegal characters, (other than 
> [a-z0-9.+-])
> ipkg-build: Please fix the above errors and try again.
> NOTE: Task failed: ipkg-build execution failed
> NOTE: package glibc-2.5-r4: task do_package_write: failed
> ERROR: TaskFailed event exception, aborting
> NOTE: package glibc-2.5: failed
> ERROR: Build of openmoko-devel-image failed
> make: *** [openmoko-devel-image] Fejl 1
> Does anybody knows what do do about that ?

Wait and try again a bit later and it might fix itself.  One of the 
frustrations I'm seeing with the build process, and it isn't the fault of 
OpenMoko per se but the OpenEmbedded way of doing things, is that with over 
4000 packages and active development going on, at any particular time the 
chance of the build database being broken is high.

Just today, I hit this -- in the morning the domain name for the cups software 
went invalid.  I waited 2-3 hours, did an update and yes indeed someone 
noticed and checked in a new hostname.  And then it broke on the lsof software 
-- an FTP directory no longer exists on their distribution host.  Grrr! 
Waited 2-3 hours, and again it got fixed.

I've also tried to use OpenEmbedded without OpenMoko, for some other devices I 
have here, as OE seems like a really cool idea.  But then that build kept 
breaking because of syntax errors (something about 'srcdate' variables) in the 
OpenMoko bitbake files that were being changed during the day -- even though 
that build did not use anything from OpenMoko.  Apparently it has to 
successfully read/parse the entire .bb fileset for a build, so if any group is 
doing development and checking in incomplete files it breaks for everyone. 
And the OpenMoko team seems to be the most active developers within OE at the 

And unfortunately, the OpenMoko build system (at least with MokoMakefile) 
always refreshes from the repository each build, so you may have a correct 
build set one time, and a broken one a few minutes later or vice versa.  I've 
tried to "freeze" the buildset so I can do my own development in peace, but 
haven't found a way to stop *all* updating.  I think some of the recipes are 
doing their own updating outside the OE/bitbake mechanisms.

Am I truly the only one seeing this?


More information about the device-owners mailing list