MokoMakefile failure while building openmoko-rssreader

Mark Brinton mark at
Sat Aug 4 20:17:25 CEST 2007

> From: "Krzysztof Kajkowski" <cayco at>
> Subject: MokoMakefile failure while building openmoko-rssreader
> Hi! I do not know if this is MokoMakefile issue or OM general. I tried
> to build openmoko-devel-image and I got error:
> ....
> | checking for WEBKITGTK... Package WebKitGdk was not found in the
> pkg-config search path.
> | Perhaps you should add the directory containing `WebKitGdk.pc'
> | to the PKG_CONFIG_PATH environment variable
> | No package 'WebKitGdk' found
> | configure: error: Package requirements (WebKitGdk) were not met:

Hi, I had the same problem as you.

I followed the instructions on the MokoMakefile wiki page:

make update-makefile ; make update ; make setup
make clean-package-<RSS-PACKAGE-NAME-GOES-HERE>
(e.g. make clean-package-openmoko-rssreader-0.0.1+svn20070722-r1)

This didn't solve my problem immediately, but I tried it again the next day, and
then the day after that and then the problem went away. My guess is that something
got updated and fixed the problem.

I'm fairly sure the version of the rss reader changed, as I still have my command history.
I started off with openmoko-rssreader-0.0.1+svn20070722-r1 and ended up with

Based on the date (20070626), maybe they want back to an earlier version?

- Mark B.

More information about the device-owners mailing list