My first day

Kero van Gelder kero at
Wed Aug 8 01:37:17 CEST 2007

> 	The dev image you installed still has the modules from the moko10 kernel, 

I ran into the same problem.
Could anyone who builds images, either
 - put the full kernel version in the filename
 - use subdirs with matching kernel + rootfs

Other things on my first day:
 - hardware is lovely, screen is gorgeous,
 - inserting microSD and SIM is slightly tricky, since you have to slide
   them into the metal covers, but the metal that wraps around those is so
   small, you don't realize that at first. A little more metal would have
   helped there.

 - there is no hardware-level feedback on the battery status (charging, full)
   as LEDs. Makes it hard to know whether it is safe to upload things (since
   apparently a 100 mA charging is not enough to charge when the Neo is active).
 - is virtually empty and the wiki does not reflect
   this. A little file saying we'd better look at
   and elsewhere would be nice.
 - having to occasionally push aux button while uploading images is... weird
 - usb0 + ssh works fine.
 - busybox has improved a lot, but its `ps` still sucks.
 - I easily get a ton of openmoko-tasskmanager zombies
 - the battery icon does not show battery level when on USB  (charging)

What constitutes a full battery??

And then I wanted to build something myself, on my laptop, so I can work
on a few things when I find time in the next three weeks when I'm to a
conference and on holiday (won't bring my Neo along).

The Openmoko Makefile breaks in `make setup` because of monotone version
incompatibility. it's at version 0.35. I'm at debian unstable, which
apparently is too bleeding edge (even though it is usually a very good
environment to build things on). Is it just me, or is 0.35 not even close
to a stable 1.0 release??

Furthermore, I find to contain too many empty directories.
the ./configure I ran can not find libgsmd and neither can I. Where is it? 
Or, which options do I pass configure to tell it to not need libgsmd?
Say, to skip certain subdirs and its deps?

In a final attempt, I tried qemu on some image. I had an old
around, but I can't use the same concept on the fresh stuff:
Is a uImage not a zImage? What is it? `file` says "u-boot/PPCBoot image"
but that means nothing to me. How do I get the kernel out?
(and the old image seems to have lost its sshd functionality, while it
hangs (at 100% CPU...) in calibrating the screen, 'coz it won't accept
my mouseclicks; I distinctly remember killing that program last time; this
image is utterly useless now)

More information about the device-owners mailing list