Using the micro-SD card

Peter Rasmussen plr at
Sun Aug 19 17:53:02 CEST 2007

I have now attempted to get the micro-SD card going, but I ran into some 
trouble and wonder if someone can tell me where I perhaps lost it?

1. The following attempt to see the state of the new card, seems to be 

# cu -l /dev/ttyACM0
In:    usbtty
Out:   usbtty
Err:   usbtty
Enabling automatic fast charge

GTA01Bv4 # mmcinit
trying to detect SD Card...
Manufacturer:       0x03, OEM "SD"
Product name:       "SU512", revision 8.0
Serial number:      2957172096
Manufacturing date: 3/2007
CRC:                0x3e, b0 = 1
size = 2329935872

GTA01Bv4 # ext2ls mmc 0
Failed to mount ext2 filesystem...
** Bad ext2 partition or disk - mmc 0:1 **
GTA01Bv4 #

2. Then I'm wondering if the GTA01 should be usable as an SD card 
reader/writer, either while running Linux or in uboot mode?
I have USB and SD/MMC support compiled in to my desktop PC kernel, using 
2.6.23-rc3, and my regular mobile phone works fine as micro-SD card 
reader/writer, but I am not able to use the GTA01 like that. I haven't 
used SD/MMC support in my desktop kernel before, but wanted to see if it 
made a difference, it doesn't.

I am not given a device file, eg. /dev/sda1, to mount the SD card when 
in the GTA01, so something seems to be missing.
I have tried to exchange the 512MB card that came with the GTA01 with 
one that I use in my mobile and is populated with files, and the result 
is the same.

Right now I have the following loaded:

./dfu-util -a 1 -R -D u-boot-gta01bv4-1.2.0+svnnow-r13_0_2632_0.bin
./dfu-util -a 3 -R -D uImage-
./dfu-util -a 5 -R -D  


More information about the device-owners mailing list