Using the micro-SD card

Brian Schrock schrock.brian at
Tue Aug 21 15:59:00 CEST 2007

I am not sure about the image you are using, but all of the images I tried
have never required extra work to use the card. All I needed to do was cd to
/media/card/ and then start writing. What does a df -h show? btw: I have
used the included 512MB and I also have a 2GB card (it has issues) that all
worked ok.

On 8/19/07, Peter Rasmussen <plr at> wrote:
> I have now attempted to get the micro-SD card going, but I ran into some
> trouble and wonder if someone can tell me where I perhaps lost it?
> 1. The following attempt to see the state of the new card, seems to be
> unsuccessful:
> # cu -l /dev/ttyACM0
> Connected.
> In:    usbtty
> Out:   usbtty
> Err:   usbtty
> Enabling automatic fast charge
> GTA01Bv4 # mmcinit
> trying to detect SD Card...
> Manufacturer:       0x03, OEM "SD"
> Product name:       "SU512", revision 8.0
> Serial number:      2957172096
> Manufacturing date: 3/2007
> CRC:                0x3e, b0 = 1
> size = 2329935872
> GTA01Bv4 # ext2ls mmc 0
> Failed to mount ext2 filesystem...
> ** Bad ext2 partition or disk - mmc 0:1 **
> GTA01Bv4 #
> 2. Then I'm wondering if the GTA01 should be usable as an SD card
> reader/writer, either while running Linux or in uboot mode?
> I have USB and SD/MMC support compiled in to my desktop PC kernel, using
> 2.6.23-rc3, and my regular mobile phone works fine as micro-SD card
> reader/writer, but I am not able to use the GTA01 like that. I haven't
> used SD/MMC support in my desktop kernel before, but wanted to see if it
> made a difference, it doesn't.
> I am not given a device file, eg. /dev/sda1, to mount the SD card when
> in the GTA01, so something seems to be missing.
> I have tried to exchange the 512MB card that came with the GTA01 with
> one that I use in my mobile and is populated with files, and the result
> is the same.
> Right now I have the following loaded:
> ./dfu-util -a 1 -R -D u-boot-gta01bv4-1.2.0+svnnow-r13_0_2632_0.bin
> ./dfu-util -a 3 -R -D uImage-
> ./dfu-util -a 5 -R -D
> openmoko-devel-image-fic-gta01-20070803091138.rootfs.jffs2
> TIA,
> Peter
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the device-owners mailing list