Using the micro-SD card

Peter Rasmussen plr at
Wed Aug 22 00:51:10 CEST 2007

I found that writing some sample files to the card in /media/card is 
possible, as can bee seen from the copy'n'paste I have below.
It does, however, make the information a bit 
out-of-date or perhaps even wrong, because it does mention using the 
"ext2ls mmc 0" right after "mmcinit" on a new card.

root at fic-gta01:~$ mount
/dev/root on / type jffs2 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
/dev/root on /dev/.static/dev type jffs2 (rw)
tmpfs on /dev type tmpfs (rw)
tmpfs on /var type tmpfs (rw)
tmpfs on /media/ram type tmpfs (rw)
devpts on /dev/pts type devpts (rw)
/dev/mmcblk0p1 on /media/card type vfat 
root at fic-gta01:~$
root at fic-gta01:~$ df
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/mtdblock4           62576     34104     28472  55% /
/dev/mtdblock4           62576     34104     28472  55% /dev/.static/dev
tmpfs                    10240        72     10168   1% /dev
tmpfs                    63328        80     63248   0% /var
tmpfs                    63328         0     63328   0% /media/ram
/dev/mmcblk0p1          495168     42896    452272   9% /media/card
root at fic-gta01:~$
root at fic-gta01:~$ df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/mtdblock4           61.1M     33.3M     27.8M  55% /
/dev/mtdblock4           61.1M     33.3M     27.8M  55% /dev/.static/dev
tmpfs                    10.0M     72.0k      9.9M   1% /dev
tmpfs                    61.8M     80.0k     61.8M   0% /var
tmpfs                    61.8M         0     61.8M   0% /media/ram
/dev/mmcblk0p1          483.6M     41.9M    441.7M   9% /media/card

However, I am still wondering if it isn't possible to use the Neo1973 as 
a card-reader/writer from my desktop PC (running Slackware), as I would 
really prefer not to have to every time I have a new image, move the SD 
card from the Neo to the PC and back. Such an excersize *will* 
eventually ruin the SD card holder in the Neo.

Then, does it also mean that I have to format the SD card to ext2 in an 
external to the Neo, card reader/writer?
Or is it possible to use the default vfat file system on the card?

Just out of curiosity, what issues have you seen with a 2GB card? I 
suppose that so far, only SD is supported, and not SDHC?


Brian Schrock wrote:
> I am not sure about the image you are using, but all of the images I 
> tried have never required extra work to use the card. All I needed to 
> do was cd to /media/card/ and then start writing. What does a df -h 
> show? btw: I have used the included 512MB and I also have a 2GB card 
> (it has issues) that all worked ok.
> On 8/19/07, *Peter Rasmussen* <plr at 
> <mailto:plr at>> wrote:
>     I have now attempted to get the micro-SD card going, but I ran
>     into some
>     trouble and wonder if someone can tell me where I perhaps lost it?
>     1. The following attempt to see the state of the new card, seems to be
>     unsuccessful:
>     # cu -l /dev/ttyACM0
>     Connected.
>     In:    usbtty
>     Out:   usbtty
>     Err:   usbtty
>     Enabling automatic fast charge
>     GTA01Bv4 # mmcinit
>     trying to detect SD Card...
>     Manufacturer:       0x03, OEM "SD"
>     Product name:       "SU512", revision 8.0
>     Serial number:      2957172096
>     Manufacturing date: 3/2007
>     CRC:                0x3e, b0 = 1
>     READ_BL_LEN=15, C_SIZE_MULT=7, C_SIZE=3453
>     size = 2329935872
>     GTA01Bv4 # ext2ls mmc 0
>     Failed to mount ext2 filesystem...
>     ** Bad ext2 partition or disk - mmc 0:1 **
>     GTA01Bv4 #
>     2. Then I'm wondering if the GTA01 should be usable as an SD card
>     reader/writer, either while running Linux or in uboot mode?
>     I have USB and SD/MMC support compiled in to my desktop PC kernel,
>     using
>     2.6.23-rc3, and my regular mobile phone works fine as micro-SD card
>     reader/writer, but I am not able to use the GTA01 like that. I
>     haven't
>     used SD/MMC support in my desktop kernel before, but wanted to see
>     if it
>     made a difference, it doesn't.
>     I am not given a device file, eg. /dev/sda1, to mount the SD card when
>     in the GTA01, so something seems to be missing.
>     I have tried to exchange the 512MB card that came with the GTA01 with
>     one that I use in my mobile and is populated with files, and the
>     result
>     is the same.
>     Right now I have the following loaded:
>     ./dfu-util -a 1 -R -D u-boot-gta01bv4-1.2.0+svnnow-r13_0_2632_0.bin
>     ./dfu-util -a 3 -R -D
>     uImage-
>     ./dfu-util -a 5 -R -D
>     openmoko-devel-image-fic-gta01-20070803091138.rootfs.jffs2
>     TIA,
>     Peter

More information about the device-owners mailing list