Can't flash smaller root-fs through dfu-util?

Igor Foox igorfoox at
Wed Aug 22 15:48:59 CEST 2007

On 8/21/07, Dr. H. Nikolaus Schaller <hns at> wrote:
> Am 21.08.2007 um 19:23 schrieb John Seghers:
> > Dr. H. Nikolaus Schaller wrote:
> >> After unsuccessfully flashing different root-filesystems, I finally
> >> found this note:
> >>> If you upload rootfs image that is smaller that previous one it
> >>> won't work - you need to attach to bootloader, erase NAND and then
> >>> upload your rootfs first:
> >>>
> >>> cu -l /dev/ttyACM0
> >>> GTA01Bv3 # nand erase rootfs
> >> This *should* help but I am trying to understand why dfu-util can't
> >> do that? And what do I do if I have no serial interface? Does this
> >> mean I can't ever again flash a (smaller) rootfs?
> >
> > I have no info on the first question, but about the serial interface.
> > The commands above actually run over USB.  Simply boot the Neo into
> > uBoot
> > (hold the Aux button while powering on) and select the option to
> > use the
> > console over USB (Move selection using Aux, invoke the selection by
> > pressing
> > power).  Then plug in the USB cable and run the "cu" command.
> Many thanks for your suggestions,
> but MacOS X has no cu command :-(
> And, I want to automate this all with dfu-util.
> BTW: the bug tracker (bugs #419, #719, #726) says it has been solved
> by a newer version of uboot - but to my experience
> it is not completely solved even by an uboot compiled 19th August.
> It looks like that contrary to the warnings on http://
> it is NOT optional.
> We all should flash a newer uboot first.
> Nikolaus

The problem is that many of us don't have a debug board, and it's a
bit scary to flash a new uboot which could brick the device. It would
be nice if some uboot builds were "blessed" so that we know we can
safely flash those without bricking the neo.

More information about the device-owners mailing list