Kernel/Rootfs flashing

Peter Rasmussen plr at
Tue Aug 28 20:57:36 CEST 2007

I now loaded these images and it was second attempt with a non 2007.01 
image (previous was from 2007.02), but they seemed similar with the GUI 
that came up.

And the functionality of these images is what worries me because they 
both mal-functioned the same way:

When the Neo has booted it comes up with a home-screen with a top-bar 
split in four (dialer, contacts, messages and calendar) a middle screen 
with  info about messages and calls and pending events and tasks, and 
finally a bottom bar with tabs for home, a large + for utilities (it 
seems) and a tools tab.

I won't go into discussions about this lay-out, but I would like to know 
if others also have experienced that when selecting the dialer from the 
home-screen, the time-piece rotates for some time, then shows the dialer 
for a second and then returns to the home page?

I am not sure about how I got there, but sometimes after having fooled 
around the OpenMoko menues for some time, I can *then* get into the 
dialer and dial a number. Even without a SIM card inserted it attempts 
to dial, and it seems to have trouble finishing a call, especially 
noticable if the other side finishes the call first.

However, my biggest complaint with these recent builds would be that 
they don't seem to provide access to a terminal, which is the only thing 
that will my mind to rest, when other things don't seem to work quite 
right. I mostly work with the Neo independently, and only with the PC 
when flashing it.


Daniel Willmann wrote:
> Hi,
> On Sun, 19 Aug 2007 18:26:45 +0200
> "Dr. H. Nikolaus Schaller" <hns at> wrote:
>> I tried to flash an alternate kernel and then did a reflash to the  
>> original one I had used the last time and which worked well.
> Did you also flash a new rootfs? This seems to be related to problem
> mentioned in
>> Any ideas?
> Please try to connect to the u-boot USB-serial console and issue
> "nand erase rootfs" then reflash the rootfs.
> If this fixes your problem you might want to consider updating to a new
> u-boot version. The image in 
> should work.
> Regards,
> Daniel Willmann

More information about the device-owners mailing list