battery not charging

Anuj Sawani xeonclub at
Fri Jan 18 01:00:46 CET 2008

I usually leave the battery out for around 10 minutes with the USB cable disconnected. 

I am using a Dell laptop to charge it. I presume they have not modified the USB standard for power-saving reasons. But, could the laptop be an issue? I have tried different USB ports on the laptop too. 

Is there a possibility that the battery is deeply discharged into an unrecoverable state?


----- Original Message ----
From: Nick Guenther <kousue at>
To: Anuj Sawani <xeonclub at>
Cc: device-owners at
Sent: Thursday, January 17, 2008 5:14:44 PM
Subject: Re: battery not charging

On Jan 17, 2008 3:05 PM, Anuj Sawani <xeonclub at> wrote:
> Hi all,
> The battery that came with my Neo went into a deep discharge state
 and now
> refuses to charge. I followed the steps at
> and left it
> overnight. I have tried this a few times too but the phone does not
 turn on
> at all.

Did you really really make sure to leave the battery out for a long
time (and disconnect the USB cable, just to be sure (not that the neo
can power itself direct from USB--which is kind of sad)) before trying
to charge it?
What are you trying to charge it from? Are you sure it is
USB-compliant (i.e. provides 100mA at all times)?


Looking for last minute shopping deals?  
Find them fast with Yahoo! Search.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the device-owners mailing list