Dial In/Out + SMS In/Out now works

Peter Rasmussen plr at udgaard.com
Sat Jan 26 22:41:40 CET 2008

I have now used about a day to test the January 25. image and it looks 
much better wrt. stability when compared to the January 23. image.

I have however, only done the following, which to me is the necessary 
phone functionality and which now seems to work every time:

1. Starting up and seeing registration
2. Dialed in and out with voice
3. Sent and received SMS messages

The UI is messy and lacking in all sorts of places, but I can live with 
that for now.

The only thing that is still a show-stopper to me is: Battery life!

Unfortunately I haven't seen much discussion about it and I would like 
to know if anyone knows if it is a no-can-do on the GTA01, or if it just 
needs more work with the software?

Unless this is solved, my Neo will never become a mobile phone, but just 
a phone that needs a cable.

After that, there are of course as ton of issues, like:

1. The ones Marc mentions below
2. International characters on the keyboard
3. How to copy-and-paste between applications
4. Control of ringing styles and vibration depending on message and 
voice caller
5. Add your own favorite missing feature :-)

Anyway, nice to at least have come this far!


Marc Verwerft wrote:
> I've tried out the new image also.
> The good:
> - while the PIN registration works each time, I see at least two
> identical network info popups
> - calling seems to work (haven't tested it thorough)
> - SMS kinda works. The second time I booted the Neo, the SMS
> application wouldn't start anymore.
> The bad:
> - I managed to 'loose' the selection of home in the top left corner of each app.
> - Managing and creating contacts is not working right
>   - I cannot select the type of phone# (work/home/...) per contact
>   - after adding the first contact the keyboard and the input field
> for the phone number started misbehaving. The keyboard would not
> disappear anymore unless I used the tiny icon at the top
> - I enabled the power management and while I was in the contacts app
> the screen dimmed after a while. I can't get the phone to wake up now
> because the keyboard is placed over the Openmoko logo that you need to
> move to unlock the phone.
> It seems that this root image was not tested before published ...
> On Jan 24, 2008 8:41 PM, Peter Rasmussen <plr at udgaard.com> wrote:
>> I have now played a little more with sending/receiving SMS with the
>> image below.
>> 1. What log file do I extract info from when sending SMS messages?
>> 2. The file /tmp/gsm.log doesn't make sense to me, but I could be wrong?
>> 3. The whole phone is actually in a big mess, because 'stability' is
>> just not there, unfortunately.
>> 4. I can sometimes send a message and I can sometimes make a voice call,
>> and mostly just after a reboot.
>> 5. It seems that more messages are received from another phone, than I
>> can send from the Neo.
>> 6. Registering to the service provider 'seems' to happen every time I
>> turn the Neo on, but sometimes it seems as if it lost the connection,
>> anyway because I can't send receive SMS or make calls.
>> 7. What do I do to confirm #6.?
>> Unfortunately bugzilla records don't seem to be dealt with, so I wonder
>> what to do about such issues? I entered a report January 4., but it is
>> still in New state.
>> If anyone can help me with set up a development environment on
>> Slackware, I might be able to help there. The info I found so far wasn't
>> really helpful there, so my only contribution so far has been testing
>> available images.
>> Peter
>> Lucas Bonnet wrote:
>>> Peter Rasmussen <plr at udgaard.com> writes:
>>>> With the recent image:
>>>> http://buildhost.openmoko.org/daily/neo1973/deploy/glibc/images/neo1973/OpenMoko-openmoko-devel-image-glibc-ipk-P1-Snapshot-20080123-fic-gta01.rootfs.tar.gz
>>>> I was able to make voice calls and messaging work on my GTA01, and
>>>> this is great progress seen from a user's perspective!
>>>> The Message UI is rather puzzling, though, I was able to use it.
>>> Indeed, now it seems to be a bit more reliable, it asks for my PIN and
>>> autoregisters at every reboot. Just in time for my OpenMoko demo next
>>> week :)
>>> I haven't managed to send a SMS though, the UI is quite puzzling, and
>>> the Random Button Pressing Technique didn't get me very far.
>>> Regards,

More information about the device-owners mailing list