u-boot-openmoko 1.3.3 (unofficial package) - testers wanted

thomasg thomas at gstaedtner.net
Tue May 20 23:03:13 CEST 2008


I'm the one who started the section "Booting from SDHC" in this wiki entry.
Actually this title is wrong (what is my "fault", even it was intended) , as
the kernel is booted from NAND and loading the rootfs isn't booting because
it's done by the kernel.
As I didn't manage to do a real boot from SDHC I'd be surprised if you
managed it - and it even isn't described in the wiki entry - so my guess is
that you are referring to "my" method.
If I'm wrong please tell me and add it to the wiki, if not I just wanted to
point out that this problem still exists and there is still no SDHC-support
in u-boot.


On Tue, May 20, 2008 at 9:38 PM, Peter Rasmussen <plr at udgaard.com> wrote:

> I have a SanDisk 6GB SDHC Class4 that I have been able to boot from for a
> very long time, at least since some u-boot-1.3.0'ish.
> The info on:
> http://wiki.openmoko.org/wiki/Booting_from_SD
> was actually rather helpful.
> What I miss, in this regard, is:
> 1.The possibility to fix the kernel that I boot from, to a partition on the
> flash-card.
> 2.The possibility to not have /etc/fstab overwritten at every reboot, so
> that I can edit it and have it stay the way I want.
> 3. Points 1. and 2. are in order to be able to have fully independent
> installations, to be able to boot up like with LILO on a desktop Linux
> installation.
> And if u-boot had USB support implemented so that I could upload an image
> from my desktop Linux straight to the flash-card without having to boot the
> Neo all the way to a Linux system, that would be really helpful, too.
> Peter
> Mike Montour wrote:
>> Marc Bantle wrote:
>>  It still doesn't recognize my Kinston 4GB card, which non of the previous
>>> versions
>>> did either, while the linux kernel does.
>> According to http://wiki.openmoko.org/wiki/Booting_from_SD that seems to
>> be a known issue (4G and up are "SDHC" rather than "SD") but I don't see an
>> entry for it in Bugzilla. It might be worth filing one, including the output
>> of the u-boot "mmcinit" command for your card.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/device-owners/attachments/20080520/1ff8945d/attachment.html

More information about the device-owners mailing list