Qtopia/X11 Weekly Status (5)

William Lai will at openmoko.com
Thu Mar 27 11:15:57 CET 2008

Wolfgang Spraul wrote:
> Holger,
>> Open issues/Todo:
>>     - Closing Qtopia apps using the 'X' button..
> How does Qtopia normally close apps? Last I heard was still that Will 
> & Sean want to get rid of the 'X' button and have a more invisible way 
> for the system to manage open applications, close them automatically 
> after a long period of inactivity or when low on memory etc. Normally 
> just leave them open. Something like that. 

Just sent an earlier email to the gta02 list (all of you were cc'ed).
I don't have a Qtopia build so I havent tried this, but No, we do not 
want 'Xs'.
Holger, have a look at the flash demo attached to that email.  Its 
pretty self explanatory.
> Will, please let Holger know what you want. Do you have a GTA01/Qtopia 
> phone somewhere? How do they close apps?
Will try this out tomorrow.
I know on Raster motorolla running Qtopia it closes with an X button.
I'll try with a Neo tomorrow.


> On Mar 27, 2008, at 6:17 AM, Holger Freyther wrote:
>> Hey,
>> another round of updates. This week I have mostly digged into kernel and
>> distribution stuff:
>>     - Make sure that the neo boots up and shows the PIN Dialog
>>     - Make sure that the neo is usable after resume
>>     - Looked into suspend/resume and modem handling
>>     - Fighting a recent OE bug making edje_cc go OOM
>>     - raster has worked on the virtual keyboard
>> Open issues/Todo:
>>     - Keyboard handling
>>     - Sleepy modem handling (after a while the modem sleeps and needs 
>> to be woken
>> up)
>>     - Closing Qtopia apps using the 'X' button..
>>     - Packaging of the illume theme...
>>     - Sound/Sound profiles
>>     - Find a edje_cc/evas/autotools fix that is working
>> In details:
>> neo bootup:
>>     We enable the modem before starting the qpe process in the 
>> 89qtopia Xsession
>> script. This gives the modem enough time to wakeup/startup before we 
>> open the
>> serial console. The timing should be fine. If you power on your neo 
>> it will
>> boot, start qtopia, start e, will ask for your pin (if you have one), 
>> will
>> register to the network...
>> neo usable after resume:
>>     With mass production in mind I had a look at suspend resume. 
>> After resume the
>> jack irq started to trigger I began to investigate, played kernel 
>> janitor on
>> the way and I'm going to look into some other issues as well. This was
>> discussed on the kernel ml
>> looked into suspend/resume modem handling:
>>     Do not spam the modem on suspend, check if the modem is talking 
>> to us after a
>> resume. This was mostly working besides the low level debugging 
>> messages sent
>> to the modem. Started to see if the modem The modem is 'sleepy' but 
>> more on
>> this later. Also tried to understand how the modem wakeup is supposed 
>> to work
>> and what the Qtopia GSM stack needs to do to make it useful, e.g. 
>> disabling
>> unsolocited messages for signal strength, network registration...
>> OE bug/edjce_cc OutOfMemory:
>>     OE managed to install the same module.so into every engine 
>> directpry which
>> will trigger recursive loading... and we will go OOM. The change was 
>> reviewed
>> by graeme and was disapproved afterwards due breaking the build. We 
>> need to
>> find a proper solution for it, and I'm working on this.
>> raster:
>>     He has started on the virtual keyboard. So you can actually enter 
>> your SIM
>> PIN without adding -ac to the X start up and launching 
>> matchbox-keyboard on
>> your host.
>> packaging of illume:
>>     E does not support system profiles. So we will have to do 
>> something evil in
>> regard to packaging until E gains support for system profiles.
>> sleepy modem:
>>     The modem is skipping the first AT command, or stops echoing 
>> after a while. I
>> have created a test program and can start to play with parameters of the
>> QAtChat to send a dummy command after a while, to send a dummy 
>> command when
>> echoing stops. This needs to be done. If all these things work, and 
>> even over
>> suspend/resume we can look into enabling the GSM muxer of Qtopia.
>> Sound/Sound profiles:
>>     Some how the git tree has a different alsa config, or drivers and 
>> the state
>> files do not work with this kernel. I need to figure this out. Also 
>> working
>> on the ALSA sound sceneraio API is on my todolist as the current 
>> approach in
>> Qtopia and PhoneKit is error prone, racy, etc. and will stop working 
>> (the
>> saving part) when we switch to a uid != 0.
>> z.

More information about the distro-devel mailing list