Setup Kicad correctly?

Lothar Behrens lothar.behrens at
Thu May 14 19:52:30 CEST 2009


I tried to follow the guide (regarding creating the symlink), but it  
doesn't work.

How exactly must the symlink setup?

I have done it that way:

mac:gta02-core lothar$ ls
audio.sch	cpu.sch		gta02-core.sch	memory.sch	scripts
components	io.sch		pmu.sch
mac:gta02-core lothar$ ln -s /Applications/Kicad/library/* .
mac:gta02-core lothar$ ls
74xx.dcm		cpu.sch			interface.lib		power.lib
74xx.lib		cypress.lib		inv.sym			power_symbol.sym
adc-dac.dcm		device.dcm		io.sch			pspice.dcm
adc-dac.lib		device.lib		linear.dcm		pspice.lib
ampli_op.sym		digital-audio.dcm	linear.lib		regul.dcm
analog_switches.dcm	digital-audio.lib	memory.dcm		regul.lib
analog_switches.lib	display.dcm		memory.lib		scripts
and.sym			display.lib		memory.sch		siliconi.lib
audio.dcm		dsp.dcm			microchip.dcm		smalland.sym
audio.lib		dsp.lib			microchip.lib		special.dcm
audio.sch		elec-unifil.dcm		microchip1.dcm		special.lib
brooktre.dcm		elec-unifil.lib		microchip1.lib		texas.dcm
brooktre.lib		et-ou.sym		microcontrollers.dcm	texas.lib
buffer.sym		gennum.dcm		microcontrollers.lib	ttl_ieee.dcm
cmos4000.dcm		gennum.lib		motorola.dcm		ttl_ieee.lib
cmos4000.lib		graphic.dcm		motorola.lib		valves.dcm
cmos_ieee.dcm		graphic.lib		nand.sym		valves.lib
cmos_ieee.lib		neg_power_symbol.sym	xilinx.dcm
components		gta02-core.sch		or.sym			xilinx.lib
conn.dcm		hc11.lib		philips.dcm		xor.sym
conn.lib		intel.dcm		philips.lib
contrib.dcm		intel.lib		pmu.sch
contrib.lib		interface.dcm		power.dcm

Then EESCHEMA still complains about missing library gta02-core- 
expanded. I copied gta02-core.lib and dcm to the required missing  
library name and
then the error message is gone. But still I don't see the components  
on the sheet. (I can open them with the library editor)

Then I have replaced the parts in the CPU sheet by them from the  
library. Now it works for CPU. The same is for MEMORY and probably the  
other sheets.
As I heard about a caching mechanism in Kicad, I think it has  
something to do with it. If I am right, the caching would be activated  
by archiving the project,
but I am not sure - I must do RTFM :-)

The is an issue with archiving on Mac (missing minizip), but I posted  
an error report to the kicad list.

So could someone test this by checking out the project at another place?

I am using Mac OS X 10.5.2 and checked out the project to /Users/ 
lothar/develop/Projects so I have

Kicad version I have, is 20090416.



-- | Rapid Prototyping | XSLT Codegeneration |
Lothar Behrens
Heinrich-Scheufelen-Platz 2
73252 Lenningen

More information about the Gta03 mailing list