Setup Kicad correctly?

Lothar Behrens lothar.behrens at
Thu May 14 21:03:24 CEST 2009

Am 14.05.2009 um 20:25 schrieb Werner Almesberger:

> Lothar Behrens wrote:
>> I tried to follow the guide (regarding creating the symlink), but it
>> doesn't work.
> Hmm, I would just add the library manually in eeschem under
> Preferences/Library/Add. Don't forget to "Save Cfg".

I had saved the Cfg :-)

>> Then EESCHEMA still complains about missing library gta02-core-
>> expanded.
> I didn't put that one into SVN since it's generated from gta02-core.
> But it may make things easier if it's there as well, so I've added it
> now. We can clean up the build process later. (There are also a few
> things I'd like to change in KiCad to make it better batch-able, so
> that will be a good moment.)
>> I copied gta02-core.lib and dcm to the required missing
>> library name and
>> then the error message is gone. But still I don't see the components
>> on the sheet. (I can open them with the library editor)
> That's to be expected, yes. The names of items from the expanded  
> library
> are prefixed with an X (to prevent KiCad from confusing them with the
> non-expanded items).
> If you check out gta02-core-expanded.lib, everything should be fine.
> (Or so I hope ;-)

With the version from svn, now I can see the symbols. But I get a hang  
when I open the PMU sheet. When I open the IO sheet,
I will get another hang when I click right in an empty area in the IO  
sheet. The same is while trying to delete a symbol from the

I have tried another project and there I haven't discovered any  
problems (usbpicproc project at
Maybe the Kicad developers could have a review at the project?

Is this a Mac OS X issue?

Or what version do you use?


> - Werner

-- | Rapid Prototyping | XSLT Codegeneration |
Lothar Behrens
Heinrich-Scheufelen-Platz 2
73252 Lenningen

More information about the Gta03 mailing list