alvieboy at alvie.com
Sat May 23 18:28:10 CEST 2009
Werner Almesberger wrote:
> Hmm, "diff" says it's the same as before ?
Hmm stupid me. Forgot to redirect diff output to proper place ;)
>>> Perhaps we should call it 74126_5 and the other would be 74126_6 ?
>> I assume you meant 74AUP1G00 :)
> Err, no, but it was wrong in several ways anyway :-) Should be 741G125_5.
> Or maybe 74X1G125_5. We don't really need the family in there, because
> you'd use the same symbol for all families (AUP, LVC, HC, whatever).
>> The symbol is the same, however the device is different - the extra 6th
>> pin is NC.
> Ah, I wish they had made life so easy for us. If you look at
> you see that VCC moves from pin 5 to pin 6. So you need different
> symbols (or make a non-standard footprint, but there lies madness).
Since I assumed '00' I missed that one. Again, it is a different device. You're right here.
>> since we're mostly using openmoko components (I assume no manufacturer
>> changes from latest GTA02) we can just add the prefix and, if we need
>> to change to some other component/outline, we add another prefix as well.
> Hmm, I'd rather have clean naming if it's not to much effort. That
> way, there are fewer traps when the library is reused.
So, just to summarize, have several (if needed) symbols of same device, with a "_N" suffix depicting the number of pins ? And remove the manufacturer prefix ?
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
More information about the Gta03