Openmoko Bug #1719: sd card not recognized

Openmoko Public Trac bugs at
Thu Aug 7 09:27:03 CEST 2008

#1719: sd card not recognized
 Reporter:  feydreva  |        Owner:  hardware
     Type:  defect    |       Status:  new     
 Priority:  normal    |    Milestone:  ASU     
Component:  hardware  |      Version:  GTA02v5 
 Severity:  normal    |   Resolution:          
 Keywords:            |     Blocking:          
Blockedby:            |  

Comment(by rhk):

 I'm not sure if this is the same bug as the one reported.. If not, I can
 file it as new:

 The SD card seems to stop working every now and then: this time again it
 might have something to do with suspend: The phone has been connected with
 the USB on the computer and was suspended once before I switched to power
 management: disabled.

 Here's some dmesg:

 But the funny thing is that you never know what's answering when you type
 ls /media/card..

 root at om-gta02:/media/card# ls /dev/|grep mmc
 root at om-gta02:/media/card# sudo mount /dev/mmcblk1 /media/card/
 -sh: sudo: not found
 root at om-gta02:/media/card# mount /dev/mmcblk1 /media/card/
 root at om-gta02:/media/card# ls
 root at om-gta02:/media/card# ls
 root at om-gta02:/media/card# cd maps/
 root at om-gta02:/media/card/maps# ls
 4free      g_road     g_terrain  osm
 root at om-gta02:/media/card/maps# cd ..
 root at om-gta02:/media/card# ls
 20080805_074751.log  20080806_091247.log  20080807_081622.log  music
 20080805_152715.log  20080806_165845.log  hp                   orrery
 20080805_191632.log  20080806_170753.log  lost+found
 20080805_202044.log  20080807_080610.log  maps
 root at om-gta02:/media/card#

 on the card I have the log files, hp, maps, music, orrery and so on, on
 /media/card (on the internal memory of the phone) I have only the maps
 folder (tangogps wrote stuff there when the card was not mounted).

 So I mounted the card as /media/card but right after the mount command it
 didn't work. Then I did something else and suddenly it works again. So
 either it's very random or mounting is slow or something..

Ticket URL: <> <>
openmoko trac

More information about the hardware mailing list