Openmoko Bug #1567: cannot re-flash the debug board

Openmoko Public Trac bugs at
Wed Jul 9 19:34:58 CEST 2008

#1567: cannot re-flash the debug board
 Reporter:  asappia   |       Owner:  hardware at
     Type:  defect    |      Status:  new                        
 Priority:  highest   |   Milestone:                             
Component:  hardware  |     Version:                             
 Severity:  normal    |    Keywords:                             
 Blocking:            |   Blockedby:                             
 Hi all,
 Yesterday evening I finally had time to check my FreeRunner and its Debug

 First of all I opened the Freerunner and made all the requested connection
 between the openmoko and the debug board (the cable and the USB
 connector), next I connected the debug board to my PC.

 I see that my USB ID 0403:6010 request I need to reflash the debug board.

 So I started my tries with linux.
 Downloaded libftdi -> applied patch from
 Hunk 1 failed ... done manual patching
 Hunk 2 Succeed with Fuzz 1
 Rechecked ftdi.c, it seems ok.

 Compiled and installed OK

 Downloaded ftdi_eeprom -> applied patch from


 Now let's try to patch
 # ftdi_eeprom --flash-eeprom ftdi_eeprom/neo1973_debug_board_v2.ftdi

 Error: No device with vendor id 1457:5118

 Ok let's see
 tried to substitute vendor id and product id inside the .ftdi, but
 Cannot Flash

 Let's try with Windows
 Downloaded MProg3.0

 Started MProg3.0
 Applied "Scan for Available Devices"
 Number Of Blank Devices = 0
 Number Of Programmed Devices = 0

 Simply I see the device connected, but I'm unable to apply the correct

Ticket URL: <> <>
openmoko trac

More information about the hardware mailing list