Openmoko Bug #1542: gps does not get fix

Openmoko Public Trac bugs at
Fri Jul 18 11:43:41 CEST 2008

#1542: gps does not get fix
 Reporter:  emdete                    |        Owner:  hardware
     Type:  defect                    |       Status:  new     
 Priority:  high                      |    Milestone:          
Component:  hardware                  |      Version:          
 Severity:  blocker                   |   Resolution:          
 Keywords:  gps antenna fix internal  |     Blocking:          
Blockedby:                            |  

Comment(by queen6):

 Replying to [comment:5 proquar]:
 > I have the same problem.
 > With the internal antenna I can wait hours and get no fix, on places
 where I usually receive ~8 satellites. Only thing I get is the time after
 about 30 minutes.
 > When I connect an external antenna I get a fix in less than 2 minutes,
 usually in less than 1 minute. I get the time after about 20 seconds.
 > If I got a fix with an external antenna and switch back to the internal
 one, it still receives all satellites it has seen before and easily
 maintains it's fix and even recovers it when I take the Freerunner inside
 for a short time.
 > I'm using a MP Freerunner, 900MHz-version, assembly was on 2008-06-18.
 (maybe it matters?)

 I've got my Freerunner 2 days ago. So far I've got the same problem
 (although I didn't have a chance to test with external antenna).

 Tried with and without SD card, standard and Andy's kernel (patched for
 GPS problems).

 MP Freerunner 900MHz, 2008-06-17

Ticket URL: <> <>
openmoko trac

More information about the hardware mailing list