Charging/powersupply trouble

Finn-Arne Johansen faj at
Thu Jan 8 23:11:57 CET 2009

Finn-Arne Johansen skrev:
> Then, on Friday (the 2nd), it was low on battery. I connected t to be
> charged, but for some reason, it was not able to take charge. This was
> using a USB-cable. I connected it to the power-supply, but I was not
> able to wake it up. Then I went for the office to get the 2nd battery (I
> ordered 2 extra batteries...), and replaced the discharged, and it
> powered up, but I was not able to "hot-swap" the batteries. OK, Lets
> leave the new one in, and let it charge over night, I thought. Next
> morning the FR was dead again.

> OK, sp now I have 3 dead GTA02 batteries. I found that my RoyalTek
> bluetooth GPS device uses somewhat similar batteries, same connectors,
> same polarity and voltage, but a bit thinner, and with the notches on
> the battery on the "other side". So I cant charge the GTA02 in the GPS,
> but I can use the 680mAh battery from the GPS in the FR.
> With the battery from the GSP, I'm able to boot and use the FR, but I'm
> not able to hot-swap the batteries. I've tried all the tips I've found
> on the wiki, trying to boot using nand/nor u-boot, powering the device
> while holding the aux-button and I dont know what. The only way I'm able
> to boot the FR, is using a battery that is charged somewhat. When teh
> device is booted, I've checked the charger-type from
> /sys/class/i2c-adapter ..../charger_type
> and also curlim_usb (or what's it called) and it seems like it's
> charging with either 500mA, or 1A. I've ordered a non-nokia
> BL-5C-charger (and battery), but it will take some days for it to
> arrive.

An update.
I charged my GPS battery for some time yesterday (30-60 minutes), and
was able to boot my FR. I connected the FR to my laptop, and the Red
AUX-light came on. I also logged into it, and checked that it charged
the device in 500mA mode. From the log of my DHCP-server, I saw that it
was active for 20 minutes with wlan powered. Then it died. I recharged
the battery in the GPS over night, and tried it this morning. Then it
should have 680 mAh. I turned it on this morning at the office, and from
the dhcp-log , it seems to be up for ~67 minutes, without suspend, with
full backlight on, wlan connected. I think the red light indicated
charging the whole time. But as said - this is not a GTA02 battery, so
maybe the charger fail to charge. but shouldnt it be able to at least
stay on ?
I guess its time to return the device for repair, or ?

Finn-Arne Johansen
faj at
EE2A71C6403A3D191FCDC043006F1215062E6642 062E6642

More information about the hardware mailing list