problem with toolchain- want to cross-compile lincity

John Lee john_lee at
Wed Jul 9 06:31:50 CEST 2008

On Wed, Jul 09, 2008 at 12:06:28AM +0200, Arne Zachlod wrote:
> Hey guys,
> i downloaded lincity 1.13.1 today from and wanted to  
> cross-compile it with the om-toolkit, but i get errors (yes, i expected  
> this ;)). I did the following:
> 1. unzipped the source
> 2. renamed the dir to lincity
> 3. copied from the openmoko sample2 into the lincity dir
> 4. run "om-conf lincity"
> 5. run ./ (here i do get the first error, but i thinks that  
> shouldn't be the problem)
> 6. run "make" (here is the fatal error what's the bigger problem)

it was a while ago but i think you don't need to run after
om-conf.  this might be the cause of error no.1.

> second error, that one after "make" is this:
> libtool: link: cannot find the library  
> `/space/fic/openmoko-daily/openmoko/staging/arm-angstrom-linux-gnueabi/usr/lib/' 
> or unhandled argument  
> `/space/fic/openmoko-daily/openmoko/staging/arm-angstrom-linux-gnueabi/usr/lib/'

you hit the '.la' libtool problem that Julian is working on.  there
was a thread about it on mailing list.

- John

More information about the openmoko-devel mailing list