opkg issues. best way to run opkg

Yohann (YC) Coppel leppoc at gmail.com
Wed Jul 16 04:20:35 CEST 2008


I just received the FR, and I try to update it using opkg.

So, first of all, I got these errors when running opkg update:
 * Failed to download
http://buildhost.openmoko.org/daily-feed/all/Packages.sig, error 404
 * Failed to download
http://buildhost.openmoko.org/daily-feed/armv4t/Packages.sig, error
 * Failed to download
http://buildhost.openmoko.org/daily-feed/neo1973/Packages.sig, error
 * Failed to download
http://buildhost.openmoko.org/daily-feed/om-gta02/Packages.sig, error

as well as "Signature check failed" for anything that is downloaded before.

Ok, but then, if I still try to run opkg upgrade, it runs, download a
lot of things, and start upgrading.
The problem is that if I run the command by ssh, the connection is cut
during the process:
Restarting Dropbear SSH server: Connection to closed by
remote host.
.... and the upgrade is probably stopped as well.

And if I run it from the terminal on the FR, the upgrade is stopped
when X restarts at some point during the process.

So, how should I run it ? (there are a lot of packages to be updated,
running the command one package at a time is excluded)

some other related questions:
Should I flash it instead ?
How can I know the version running on the FR ?

Thank you!
And big applause for all the work done (GPS, etc, I believe you will
find a solution ! GL!)



More information about the openmoko-devel mailing list