GTA01V3/V4 LCD framebuffer problem

Nils Faerber nils.faerber at
Sat Jul 21 16:45:57 CEST 2007

Arnaud Patard (Rtp) schrieb:
> Nils Faerber <nils.faerber at> writes:
> Hi !


>> I am currently trying to get suspend/resume working with the current NEO
>> GTA01 devices and encountered a strange issue...
> Bv3 or Bv4 ? I may be wrong but iirc there was some suspend/resume
> troubles on Bv3 hardware.


>> I looked through the s3c2410fb.c code and found it to be appearingly
>> good, concerning suspend/resume. So in theory it should work just that
>> it does not.
> well, the s3c2410fb driver suspend/resume is working fine on my h1940
> and I didn't get any report that it was not working.

That's what I was also suspecting after having looked into it. So it
must be something rather NEO specific, either in the platform
suspend/resume or just something minor thing dealing with the concrete

>> So any hint where and what for to look would be greatly appreciated! I
>> am willing to do the work, I am just new to this platform and need some
>> hints where to look for such kind of glitches...
> If you're not in a big hurry for this issue to be solved, I'll try to
> find some time this week-end to try to reproduce and fix this bug on my
> neos. 

That would be really great!
If you need any further information from mee for this please tell me! I
will do everything to help out.

Though there is no real hurry for me it would be great to have this
issue resolved quite soon since more and more NEOs now get shipped and
find their way to new users...

Man thanks!

> Regards,
> Arnaud
  nils faerber

kernel concepts GbR      Tel: +49-271-771091-12
Sieghuetter Hauptweg 48  Fax: +49-271-771091-19
D-57072 Siegen           Mob: +49-176-21024535

More information about the openmoko-kernel mailing list