Modem wakeup...

Nils Faerber nils.faerber at
Tue Jul 24 12:59:08 CEST 2007

Arnaud Patard (Rtp) schrieb:
> Nils Faerber <nils.faerber at> writes:
> I've no idea on how the modem is working too but at least I can see that
> there's a irq handler for a "modem wakeup" interrupt. Unfortunately, I
> don't see where the gpio is configured to do interrupts.
> Can you try adding :
> s3c2410_gpio_cfgpin(GTA01_IRQ_MODEM, S3C2410_GPF1_EINT1);
> before set_irq_type(GTA01_IRQ_MODEM, IRQT_RISING); in
> mach-gta01:gta01_machine_init() ?

Something is very strangenow...
If I add the above command the NEO does not boot-up anymore, "kernel
panic, unable to mount rootfs, tried jffs2".

I tried several times, both on V3 and V4.
After I removed the command again everything returned to normal, device
What side effect could
	s3c2410_gpio_cfgpin(GTA01_IRQ_MODEM, S3C2410_GPF1_EINT1);
possibly have concerning the NAND Flash?

This is weird...

> Arnaud
  nils faerber

kernel concepts GbR        Tel: +49-271-771091-12
Sieghuetter Hauptweg 48    Fax: +49-271-771091-19
D-57072 Siegen             Mob: +49-176-21024535

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: OpenPGP digital signature
Url : 

More information about the openmoko-kernel mailing list