Modem wakeup...

Arnaud Patard (Rtp) arnaud.patard at
Tue Jul 24 13:45:23 CEST 2007

Nils Faerber <nils.faerber at> writes:

> Arnaud Patard (Rtp) schrieb:
>> Nils Faerber <nils.faerber at> writes:
>> I've no idea on how the modem is working too but at least I can see that
>> there's a irq handler for a "modem wakeup" interrupt. Unfortunately, I
>> don't see where the gpio is configured to do interrupts.
>> Can you try adding :
>> s3c2410_gpio_cfgpin(GTA01_IRQ_MODEM, S3C2410_GPF1_EINT1);
>> before set_irq_type(GTA01_IRQ_MODEM, IRQT_RISING); in
>> mach-gta01:gta01_machine_init() ?
> Something is very strangenow...
> If I add the above command the NEO does not boot-up anymore, "kernel
> panic, unable to mount rootfs, tried jffs2".

oh :(

> I tried several times, both on V3 and V4.
> After I removed the command again everything returned to normal, device
> boots.
> What side effect could
> 	s3c2410_gpio_cfgpin(GTA01_IRQ_MODEM, S3C2410_GPF1_EINT1);
> possibly have concerning the NAND Flash?

too bad. My fault. sorry :(

This should have been:
s3c2410_gpio_cfgpin(S3C2410_GPF1, S3C2410_GPF1_EINT1);


More information about the openmoko-kernel mailing list