[PATCH] GPS power management for GTA02

Jim Huang jserv at openmoko.org
Tue Oct 9 16:39:14 CEST 2007

Hash: SHA1

Harald Welte 提到:
> On Tue, Oct 09, 2007 at 02:51:18PM +0800, Jim Huang wrote:
>> This patch creates a working GPS PM driver reflecting the changes in PMU
>> pcf50633 controls.
> I wonder whether we should just merge this with gta01_pm_gps.c and
> rename it to neo1973_pm_gps.c (and move it to arch/arm/mach-s3c2410, but
> that's a different issue).

hi Harald,

I thought using gta01 as prefix is misleading, and so I renamed it.
Yes, the naming with neo1973_ prefix is better and makes sense for both
GTA01 and GTA02.

> The code is very common, and the userspace application doesn't really
> care what exact GPS chipset is underneath.  Yes, GTA01 has way more
> fine-grained controls.  but the "echo 0/1" > power_up could be made
> working on both GTA01 and GTA02.
> What do you think, jserv?

I agree.  Since user-space applications only care about the way to power
on/off GPS device, we shall use the same naming and sysfs entry.  The
consideration is similar to GSM modem, but the later involves in more
conditions such as hardware configurations and pin assignments.

- -jserv
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the openmoko-kernel mailing list