vibrator PWM support

Michael 'Mickey' Lauer mickey at
Wed Sep 12 01:32:20 CEST 2007

Richard Purdie wrote:
> On Sun, 2007-09-09 at 12:39 +0200, Michael 'Mickey' Lauer wrote:
>> Javi Roman wrote:
>> > Please let me know what's wrong, or some other kind of feedback.
>> > BTW, I wonder if it's better to create a new class driver for vibrator
>> > rather than led class.
>> Why? That would be a 100% duplicate, since the feature-set is entirely
>> the same. I'd rather rename the "LED class" "Indicator class" if
>> people have problems with the slightly misleading name.

> I'm ok with the vibrator being part of the LED class but I would prefer
> to keep the existing name since changing it would break the API now. I
> don't think duplicating the code makes much sense.

That's what I hoped for from the LED class maintainer -- thanks. (The
proposed name change wasn't meant very serious anyways).


Michael 'Mickey' Lauer | IT-Freelancer |

More information about the openmoko-kernel mailing list