vibrator PWM support

Richard Purdie rpurdie at
Tue Sep 11 23:34:48 CEST 2007

On Sun, 2007-09-09 at 12:39 +0200, Michael 'Mickey' Lauer wrote:
> Javi Roman wrote:
> > Please let me know what's wrong, or some other kind of feedback.
> > BTW, I wonder if it's better to create a new class driver for vibrator
> > rather than led class.
> Why? That would be a 100% duplicate, since the feature-set is entirely
> the same. I'd rather rename the "LED class" "Indicator class" if
> people have problems with the slightly misleading name.

I'm ok with the vibrator being part of the LED class but I would prefer
to keep the existing name since changing it would break the API now. I
don't think duplicating the code makes much sense.



More information about the openmoko-kernel mailing list