[Bug 79] suspend/resume to RAM support

bugzilla-daemon at bugzilla.openmoko.org bugzilla-daemon at bugzilla.openmoko.org
Mon Apr 14 11:54:54 CEST 2008


------- Additional Comments From reddog at mastersword.de  2008-04-14 11:54 -------
I didn't tested the GPS stuff.

I booted with the new kernel from mwester, all seems to be fine.

1st try:
-Entered suspend via "echo mem > /sys/power/state" ... ok
-Woke it up by the power-btn ... ok
-Can't see something very special in dmesg
-Power-menu works :-)  very good work! thanks!
-I don't know if sound works ... madplay	says /dev/dsp busy!
openmoko-mediaplayer (wich looks very nice btw) says that i don't have the
gstreamer decoder plugin installed if i try to play an mp3. Will later try sound
when it's freshed booted (then it works for shure, because i can here the
startup sound)
-GSM seems to work, dialed my second number and it ring. I'm in train and GSM
registers to different networks, all seem to be fine! At this point i have to
say, that i have removed the console=xyz boot option in uboot!

2nd try:
- Also entered suspend via "echo mem > ..." because i don't know any other way
for it atm.
- Woke up by AUX-btn
- I tried to call my second phone, but my second phone doesn't ring. Instead of
a ringing phone, i could here a nice voice, wich told me that "the number you
are calling is temporary not available..."! Very nice, my old nokia sometimes
has a problem with network registration, but this shows me, that the sound
generally works!
- Power menu again works... very nice! :D

3rd try:
- Woke up by power-btn
- Again, with my limited knowledge, i can't see anything special in dmesg
- This time, i tried to receive an sms. It worked, but openmoko-messages put the
message in the wrong folder! I opened a new Bug.
- Then i sent a sms, and it worked also.

The next 4th to 7th tries, it woked up fine by using the power-btn.

8th try:
Woked up by AUX-btn

9th try:
I used my second phone to call neo ... neo woke up, shows incoming call, but
doens't ring!

10th try:
I used again my second phone to send a sms to he neo ... nothing ... 
Woke up by AUX-btn ... waiting ... no sms!! Hmm, who got my sms?? I, looked at
send-objects on my nokia and it shows me, that i sent the sms to the neo. Bad!

11st try:
Woke up by AUX-btn

12nd try:
Woke up by (uh .. forgotten)

13th try:
Woke up by power-btn

14th try:
Woke up by aux

Now my time is over ...

I will send it to sleep and will later look at battery status...
now it is 10:40


So i'm back and it is 11:40, one hour later!
I pressed AUX-btn: now it got a white screen but it is awake, i can ssh into it.
apm says:
Off-line: 94%

so about 6% in one hour, if we could trust this apm message.

I thought to give it a try to suspend again:
-echo mem > ...
-woke up by AUX-btn, but again white screen!

A restart of x doesn't help, it has again a white screen. But it has vibrated,
that could be the missing sms?

Now i reboot the phone!

I attach the last dmesg (20080414.dmesg), in it are some old lines and the
latest after the white screen.

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the openmoko-kernel mailing list