[Bug 79] Dealing with GTA01 breakage

Mike (mwester) mwester at dls.net
Tue Apr 15 05:16:18 CEST 2008

Andy Green wrote:
> Somebody in the thread at some point said:
> | Good news: for no discernible reason, my git fetch suddenly worked, so I
> | have the latest git kernel...
> What branch is that?

:) Whatever the default branch is for use in OE; I haven't actually 
checked.  I can see the latest commits, though, and that's been good 
enough for the moment.

> | Not-so-good news: ...it's badly broken on the gta01 :(   It panics on
> | shutdown, suspend crashes and requires the battery to be removed to get
> Do you have a copy of the panic?

It's a heisen-bug, it seems.  I can only see it once-in-a-while, and 
never when I have anything connected to the neo that can log the panic. 
  That behavior might be a clue, I hope.

> | the device back.  No audio (or too low to hear in my automobile).
> If your tree is not recent, "no audio" can be due to changes in the
> audio driver, new mixer controls appeared in the last few weeks.  I saw
> errors on alsactl restore from the mismatch and was able to get stuff
> working by meddling with alsamixer and then alsactl store.

I tried the new kernel with an older rootfs and got audio, so I expect 
this is not a kernel issue directly.  The audio is relatively low on my 
list right now, compared to the panic and the failure to suspend/resume.

> | So for the moment anyone who wishes to test a kernel that seems to
> | behave better on the gta01 wrt suspend/resume can't get it from the
> | normal places; instead fetch the kernel from http://moko.mwester.net/ .
> In the longer run if GTA01 is going to keep working without excessive
> pain the answer is either for GTA01 folk to run their own tree (eg, an
> "mwester" branch) cherrypicking and testing new patches in parallel, or
> for a more regular tracking of the stable tree in git and reporting
> breakage pretty close to when we broke it.  After we fix whatever these
> issues are.

The current urgent need is to catch up to the current development HEAD, 
and return the GTA01 functionality to at least the 2.6.22 kernel level.

The fundamental problem is rooted in a misunderstanding; the community 
believed (since there was never any indication to the contrary) that the 
GTA01 was being maintained by Openmoko.  The result is that we're now 
faced with fixing stuff that has never worked for the GTA01 since the 
2.6.24 transition, on top of keeping the GTA02 changes from impacting 
the GTA01 negatively.  No amount of branching or cherrypicking will fix 
that problem, I'm afraid.

(Compounding this problem is the current git/OE issue -- it randomly 
fails for a number of folks; until we can figure out what that is and 
get a reliable way to keep the community in sync with the master repos, 
reporting breakages is going to be hit or miss, I'm afraid.  Hopefully 
this git/OE issue will be resolved soon.)

We're going to need a *LOT* of help with the GSM suspend/resume thing. 
That's the area where I'm most worried, as I think the community lacks 
the necessary documentation from TI, but also the information on how it 
is supposed to work, and how it actually does work for each of the 
several firmware versions out in the field.  I completely understand 
that we can ask OM questions, and you'll try to answer -- but I'm sure 
that the engineers at OM understand that the problem in so many cases is 
that one doesn't have enough information to know what question to ask. 
We'll cross that bridge when we get there; hopefully soon.

> - -Andy

Mike (mwester)

More information about the openmoko-kernel mailing list