Fwd: [gta02] u-boot boot menu regression ?

Wolfgang Spraul wolfgang at openmoko.com
Wed Apr 16 16:55:59 CEST 2008

Begin forwarded message:

> From: Werner Almesberger <werner at openmoko.org>
> Date: April 16, 2008 9:55:30 PM GMT+08:00
> To: Andy Green <andy at openmoko.com>
> Cc: gta02 <gta02 at lists.internal.openmoko.org>
> Subject: Re: [gta02] u-boot boot menu regression ?
> Andy Green wrote:
>> Just a thought, maybe you can change this to act like that if there  
>> was
>> no valid environment in NAND, that might meet the request and be a
>> reasonable behaviour for users too, without having special modified
>> builds for factory.
> Like this ? I kind of doubt this solves Miles' problem, though.
> All you get is the boot menu that offers you "Boot", which of
> course doesn't work, since you don't have the partition table.
> ObWolfgang: the reason why I'm not sending this patch to the
>  public list is that it's probably useless and I don't even
>  think I understand where in the factory the problem is. In
>  case that patch should turn out to be useful, I'll be happy
>  to repost it ;-)
> Cheers, Werner
> _______________________________________________
> gta02 mailing list
> gta02 at lists.internal.openmoko.org
> https://lists.internal.openmoko.org/mailman/listinfo/gta02

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/openmoko-kernel/attachments/20080416/8387d0f6/attachment.htm 
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: menu-unless-env.patch
Url: http://lists.openmoko.org/pipermail/openmoko-kernel/attachments/20080416/8387d0f6/attachment.txt 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/openmoko-kernel/attachments/20080416/8387d0f6/attachment-0001.htm 

More information about the openmoko-kernel mailing list