s3c244x hardware ecc / backup kernel and rootfs direction

Werner Almesberger werner at openmoko.org
Thu Aug 14 16:16:23 CEST 2008

Andy Green wrote:
> We need a name that describes what it does, not a name shrouded in
> nudge-nudge references.  "Factory initialization" is fine.

We have two things that may need new names:

- the one currently called kboot-stage1. The "stage1" part is good,
  but I feel that the "kboot" part will lead to confusion, since
  there are too many things that are being called "kboot".

  That's the one I suggested we could call "figleaf".

- the one currently called devirginator. Politicial correctness,
  aside it also makes sense to give this a new name for GTA03,
  since almost the entire process changes, so there's no point in
  trying to adapt the existing devirginator. (We can steal a few bits
  from it, though.)

  This is the one Mike suggested to call "initial flash". (Which
  seems descriptive enough to me, and "ini-tial flash" leaves my
  tongue in a lot fewer knots than "fac-to-ry ini-tial-i-za-tion".)

- Werner

More information about the openmoko-kernel mailing list