s3c244x hardware ecc / backup kernel and rootfs direction

Andy Green andy at openmoko.com
Thu Aug 14 16:37:02 CEST 2008

Hash: SHA1

Somebody in the thread at some point said:
| Andy Green wrote:
|> We need a name that describes what it does, not a name shrouded in
|> nudge-nudge references.  "Factory initialization" is fine.
| We have two things that may need new names:
| - the one currently called kboot-stage1. The "stage1" part is good,
|   but I feel that the "kboot" part will lead to confusion, since
|   there are too many things that are being called "kboot".
|   That's the one I suggested we could call "figleaf".

Hey Xiangfu, you did most of the work on that thing, do you have a good
name you would like to use for it?

|   This is the one Mike suggested to call "initial flash". (Which
|   seems descriptive enough to me, and "ini-tial flash" leaves my
|   tongue in a lot fewer knots than "fac-to-ry ini-tial-i-za-tion".)

I don't mind if folks want to call it "initial flash", "factory
initialization" is such a functional name though I will probably use it too.

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the openmoko-kernel mailing list