s3c244x hardware ecc / backup kernel and rootfs direction

xiangfu xiangfu at openmoko.org
Fri Aug 15 17:37:58 CEST 2008

Andy Green wrote:
> Somebody in the thread at some point said:
> | Andy Green wrote:
> |> We need a name that describes what it does, not a name shrouded in
> |> nudge-nudge references.  "Factory initialization" is fine.
> |
> | We have two things that may need new names:
> |
> | - the one currently called kboot-stage1. The "stage1" part is good,
> |   but I feel that the "kboot" part will lead to confusion, since
> |   there are too many things that are being called "kboot".
> |
> |   That's the one I suggested we could call "figleaf".
> Hey Xiangfu, you did most of the work on that thing, do you have a good
> name you would like to use for it?
i have no ideas , figleaf is OK. i search the word with google Dictionary.

"The term is a metaphorical reference to the Biblical Book of Genesis,
in which Adam and Eve used fig leaves to cover "their nakedness" after
eating the fruit from the Tree of Knowledge of Good and Evil."

the kboot-stage1 just do a little thing on "nakedness GTA02" :-) ,
if something wrong forget it, i am not good at English. :-)

> |   This is the one Mike suggested to call "initial flash". (Which
> |   seems descriptive enough to me, and "ini-tial flash" leaves my
> |   tongue in a lot fewer knots than "fac-to-ry ini-tial-i-za-tion".)
> I don't mind if folks want to call it "initial flash", "factory
> initialization" is such a functional name though I will probably use
> it too.
> -Andy

More information about the openmoko-kernel mailing list