Openmoko Bug #1849: mmcinit error with the SD card that came with the phone

Openmoko Public Trac bugs at
Fri Aug 22 15:01:30 CEST 2008

#1849: mmcinit error with the SD card that came with the phone
 Reporter:  enrico           |          Owner:  openmoko-kernel
     Type:  defect           |         Status:  new            
 Priority:  highest          |      Milestone:                 
Component:  System Software  |        Version:                 
 Severity:  normal           |       Keywords:                 
Blockedby:                   |   Reproducible:  always         
 Blocking:                   |  

 From inside u-boot, if I run "mmcinit", I get:

 GTA02v6 # mmcinit
 cmd 0x8, arg 0x1aa flags 0x75
 Error after cmd: 0xfffffffc
 Card Type:          SD
 Manufacturer:       0x1b, OEM "SM"
 Product name:       "SMI  ", revision 1.0
 Serial number:      504689075
 Manufacturing date: 11/2007
 MMC/SD size:        497MiB

 mmcinit somehow succeeded anyway, as afterwards I can access the card and
 load a kernel from it.  Boot menu options that load from SD also work
 fine, except you can shortly see that they print that error message.

 The microsd card is the one that came with the phone. For completeness,
 here is what is written on it:

   Transcend 512mb
   I 82710000 745
   Made in TAIWAN
   191574 2193

 This happened with the stock u-boot as well as with u-boot
 gta02v5-20080805 and gta02v5-20080820.  I'm currently running
 gta02v5-20080805.  The phone is a GTA02v6.

 Googling gave me no hits except this mailing list message of someone with
 the same problem:

Ticket URL: <> <>
openmoko trac

More information about the openmoko-kernel mailing list