WPA / 54G WLAN success on A5 here :-D

Samuel Ortiz sameo at openedhand.com
Fri Feb 1 11:56:14 CET 2008

Hi Andy,

On Fri, Feb 01, 2008 at 10:43:44AM +0000, Andy Green wrote:
> Hash: SHA1
> Hi Sameo -
> Wah lovely stuff, was able to configure wpa_supplicant by hand and use
> udhcpd to get right on my local WLAN and stay there until now anyway.
Excellent :-) So, that's a WPA AP, right ? And you managed to get a
DHCP offer from the AP ?
I currently have 2 bugs with our 2.0 firmware:
1) with my AP, my module doesn't hear the AP's DHCP offer unless I switch
it to full power (no power saving).
2) If I scp a big file from another machine to /dev/null, the link stalls,
and it looks like the module is dead.

Atheros is saying that this could be related to my AP, so I'd be really
happy if you could run test 2) on your network.

> Somehow on the rootfs I used /etc/resolv.conf ends up on
> /var/volatile/run/resolv.conf that is somehow always 0 length even when
> I overwrote it.  I moved the /etc/resolv.conf symlink out of the way and
> made a regular file right there and it worked fine.
> Seems to be fine with light stress with wget, ceiling for http was
> 450KBytes/sec saving to /dev/null.  Pretty respectable for this kind of
> device!
Yeah, it's not too bad. Are you running with the peripheral clock at 50 Mhz ?
Also, do still get the spinlock BUG() you were frequently getting ?

Lots of questions, sorry :-/


> Good job!
> - -Andy
> Version: GnuPG v1.4.7 (GNU/Linux)
> Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org
> iD8DBQFHovfgOjLpvpq7dMoRAt+CAJ4iRzgCxbJLVzort8i2pHoGgrCgGACaAoIu
> NoCwyE/yL9phnaSxOnPxrtM=
> =uHXq

More information about the openmoko-kernel mailing list