Mokoptach series doesn't apply

Andy Green andy at
Sun Feb 24 07:08:00 CET 2008

Hash: SHA1

Somebody in the thread at some point said:
> Andy Green wrote:
>> This is getting insane now.  I tried both going to master and deleting
>> the whole tree, and checking it out from git again; and when that failed
>> I recloned the git tree and tried to import the mokopatch
>> series, same failure.
> Hmm, could it be that the git tree you get from differs from
> the linux-2.6.24.tar.bz2 ? What command exactly do you use
> to get that tree ?

No it's definitely different mokopatches that are not forced back to
compliance with upstream svn when you do "svn update".  svn update says
that you are at such and such a revision but in fact it apparently does
not look at what you have got on your side at all to make such an assertion.

My procedure was to git clone the linus tree and then

$ git reset --hard "v2.6.24"

gets you teleported to that tag's patchlevel.  This never made any
problems and gave clean 2.6.24 from current git.

- -Andy
Version: GnuPG v1.4.7 (GNU/Linux)
Comment: Using GnuPG with Fedora -


More information about the openmoko-kernel mailing list