mount time (was Re: Fwd: Hello -- NAND/NOR Flash design for GTA02)

Werner Almesberger werner at
Thu Jan 17 17:35:17 CET 2008

Andy Green wrote:
> Yep it's cool, I didn't realize at first that the JFFS2 mount delay was
> missing because I just accepted to start reading the next bit.

Cool :-) So I think we can keep is simple and just proceed with one
partition for the rootfs.

> (Touchscreen didn't work on the device I put that image on,

Hmm, that makes us two who don't have a touchscreen on GTA02 :-(
I also tried the kernel with the same result. Seems
that this wants looking into.

> Now the usermode stuff looks very slow indeed.  It still finishes 2 min
> after the kernel came up here.

Now that's ugly :-(

Things I have on my to do list now are, in no particular order:

- make myself a small EABI rootfs (still using the OABI one from
  HXD8 for some experiments)
- give LogFS a quick spin, just out of curiosity
- hwecc fix in
- switch USB IDs
- finish NOR integration, all the way to the devirginator
- update the partition layout
- merge today's pending patches from you and Willie
- merge you u-boot splash screen patch
- fix the accelerometer driver
- find out what's happening with the touch screen
- make 2.6.24 happy with the GTA01
- rebase on 2.6.24-rc8

Seems that next week, power management (suspend/resume/charging/general
drain) wants to have some good looking into. Do you have any plans for
that area at the moment ?

- Werner

More information about the openmoko-kernel mailing list