[PATCH] fix-data-abort-from-sd-ombug799.patch

Andy Green andy at openmoko.com
Wed Jul 16 09:15:19 CEST 2008

Hash: SHA1

Somebody in the thread at some point said:
| Andy Green wrote:
|> ext2 never worked for me last I tried it, it just failed to parse the
|> filesystem I think rather than aborted, is it working for you after
|> this?  It would simplify SD Card boot a bit since we have a VFAT
|> partition first to allow kernel to be picked up by U-Boot currently.
| Without the patch, accessing an ext2/ext3 filesystem causes some sort of
| stack corruption that can have various symptoms (not always the same
| error message). As noted in the Trac entry (#799) the root cause of this
| is still unknown.

Hah sounds like the same deal then, nice fix to have.

| With the patch I am able to execute 'ext2ls' and 'ext2load' reliably,
| and I have been running with an ext3 SD-card rootfs (including kernel)
| on my GTA01 for several months. I don't have access to a GTA02 so I
| can't test it there.

This stuff'll be the same on GTA02 as 01, it sounds like one partition
ext2 / 3 might be back on the table for SD Boot, I will give it a go later.

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the openmoko-kernel mailing list