Ar6K Driver problems

Arnaud Derasse arnaud.derasse at
Thu Jul 17 13:15:20 CEST 2008

Hello ,

I already sent a mail on this list and we solved the problem by 
ourselves, it was an hardware electrical problem.

Now we have a new problem, with software this time and really strange :
We can associate to an AP , we can ping with all packet size, all other 
the world. But when we try a wget or ssh or ftp .. we have a problem.

Accton tell us they will need our developpement card and driver to make 
tests. But I just would like to know what is the problem, according to 
the log files.

Since at OpenMoko you have a good experience of Ar6K, can somebody just 
give a look at the attached log file and tell me if you know why this is 
happening  :
We have a "Target debug interrupt" from Ar6K after wget then, the Ar6K is not responding anymore.

When we try to ssh from the network to the ar6k target, we have mostly 
the same log, with the same error and same behavior after the last debug 
output : Nothing more happen. We can't ping, we can't do anything.

Another thing I don't understand is : What is the difference in the Ar6K 
point of view between a ping and a wget ?? Ar6k is just transmitting and 
receiving packets, doesn't it ?

Thank you

Arnaud Derasse
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ar6k-wdg002-wget.log
Type: text/x-log
Size: 5997 bytes
Desc: not available
Url : 

More information about the openmoko-kernel mailing list