Merge into stable

Werner Almesberger werner at
Fri Jul 18 23:58:10 CEST 2008

Holger Freyther wrote:
> I think we should merge the 2.6.24.x series into our stable branch.

Or maybe just move to 2.6.26 ? 2.6.24 is getting old, and there doesn't
seem to be any overwhelming need for having perfectly stable kernels
every day at the moment. (I.e., no factory image with urgent fixes is
being branched right now. ASU can probably survive a few days without
new kernel changes.)

Andy mentioned a few blockers he's been watching for a time. How hard
would it be to fix these ?

The longer we stay at an old kernel, the harder it will be to catch up.
I made the mistake of stopping to upgrade once in a project (linux-atm,
after some major changes to the networking infrastructure), and getting
back on track took about a year and required a lot of help from outside
the project.

- Werner

More information about the openmoko-kernel mailing list