Backup battery discharged -> GTA01 and GTA02 dead

Rod Whitby rod at
Sat Jul 19 15:01:28 CEST 2008

Andy Green wrote:
> Somebody in the thread at some point said:
> | Will a backup battery voltage of 0.4V or 0.7V instead of 2.0V cause a
> | GTA01 or GTA02 to appear to be completely dead and never power on?
> Not directly... if your main battery is really discharged it can make
> the trouble, and the backup battery state is just a side-effect of that.

I have tried to boot all three "dead" devices with externally charged 
main batteries measured at 4.1V, with no success.  I have also tried to 
boot the GTA02 with the wall charger and a good main battery - also no 

> If you can bring the battery level up enough to get started, it will
> start and commence to charge normally.  For example, a second battery
> that is not discharged.  I cannot recommend anyone does it, but I found
> that connection from USB V+ to battery V+ during startup will do it.
> This briefly pulls >500mA from the USB host and could conceivably do bad
> things, so I am not recommending it, just filling you in.

Are you talking about the main battery here, or the backup battery?  If 
you are talking about the main battery, then that's not the problem - I 
have perfectly fine charged main batteries.

> We have plans to provide software updates that disallow the main battery
> from getting discharged enough under normal circumstances to get into
> this trap.

Yes, but in the meantime, how do I get out of the trap which causes a 
discharged backup battery to stop device operation, even with a 
fully-charged main battery and openmoko usb wall charger plugged in?

-- Rod

More information about the openmoko-kernel mailing list