Backup battery discharged -> GTA01 and GTA02 dead

Rod Whitby rod at
Sat Jul 19 15:27:39 CEST 2008

Andy Green wrote:
> Somebody in the thread at some point said:
> | Yes, but in the meantime, how do I get out of the trap which causes a
> | discharged backup battery to stop device operation, even with a
> | fully-charged main battery and openmoko usb wall charger plugged in?
> I can only talk about GTA02 since that's all I know... low or dead
> backup battery only sends PMU into NOPOWER state when you remove the
> main battery and USB, where certain defaults apply, but if you have an
> OK main battery then even these "NOPOWER" defaults are good to boot the
> thing.  I don't think you need a good backup battery level to get a boot
> on GTA02.
> On GTA02, try NOR boot in case the NAND is crapped on somehow, hold in
> AUX corner button, then power for a while then let of of AUX, then power.

I've already tried NAND boot, NOR boot (many times over a number of 
weeks will externally full-charged batteries and openmoko wall charger) 
and even tried getting a response using the Debug Board.  No dice.

Are you 100% sure that a good backup battery level is not required for 
boot on a GTA02v5?  Who can answer that for GTA01Bv4?

Is there an easy way that I can test my theory that a dead backup 
battery causes a dead device?  Is there a test point on the GTA02 I can 
look at to debug whether the PMU is powering up the device or not?

Is there a safe way to recharge the backup battery in-circuit using 
external means when it's voltage is this low and the device refuses to 

If the battery cannot be easily recharged, what is the exact type of 
battery used for the backup battery, and how is it attached to the board 
(it seems to be soldered in) - what is the easiest way to detach or 
desolder the current battery and install a new one?

-- Rod

More information about the openmoko-kernel mailing list