Backup battery discharged -> GTA01 and GTA02 dead

Rod Whitby rod at
Mon Jul 21 10:37:24 CEST 2008

Werner Almesberger wrote:
> Rod Whitby wrote:
>>  Is there a test point on the GTA02 I can  
>> look at to debug whether the PMU is powering up the device or not?
> You could monitor nRESET. It rises to ~3.3V when the PMU thinks power
> is stable enough to allow the system to leave reset.

OK, this GTA02 is behaving very strangely.  I now have a backup battery 
which is showing 2V and a main battery showing 4.1V, but still no 
ability to reliably boot the device.

Here's the sequence I'm trying:

1) Remove main battery and wall charger usb power.
2) Push aux and power buttons to try and drain any caps on the board.
3) Insert main battery.
4) Attach wall charger usb power.
5) Push AUX button, and keep it pushed.
6) Push Power button, and hold for 20 seconds.
7) Release AUX button (I tried releasing it at various times before, 
during and after step 6).

Neither this sequence, nor any variations on that sequence, will 
reliably boot the device.

*Sometimes* (about 1 out of 20 attempts) I get a brief flash on the red 
led.  *Very Rarely* (about 1 out of 50 or 100 attempts) I actually get 
the device to boot (and run the qtopia image that I flashed on there 
months ago to try out), but never as a result of the normal NOR boot 
sequence.  However, once it's booted as soon as I try and reboot it so I 
can get it into dfu-util mode and flash a new firmware image, I'm back 
to trying for another 100 or so times before I can hope to get it to 
boot once again.  *Never* have I been able to get it to boot twice in a row.

This device is running u-boot 1.3.2-rc2 if that makes any difference.

I'm monitoring the nRESET line at various points in the sequence above, 
and I've never seen it go above 0V.  Of course in the very rare instance 
the it does boot, I'm not monitoring nRESET (I haven't got the patience 
to hold a multimeter on a test point, hold the battery in manually, and 
push two buttons at the same time).

So, any ideas on what could be causing this?

Knowing that the batteries and usb charger are fine, and that nRESET is 
still low, what's the next level of debugging I can try - how do I work 
back from the nRESET test point to the PMU pins to find out what's going 

-- Rod

More information about the openmoko-kernel mailing list