My Gta02s wont charge

Wolfgang Spraul wolfgang at
Wed Jun 18 04:54:14 CEST 2008

Nokia batteries BL-4C, BL-5C and BL-6C should all work fine in both  
GTA01 and GTA02. Also any clones of those batteries (we tested  
several, all worked).
Additionally, try to get an external battery charger (again, because  
of the Nokia compatibility it should be easy to get one, look for  
BL-5C external charger or so).
I believe we still may have a bug where we cannot charge batteries  
from a very deep discharge in the phone. Not even via the official  
Openmoko charger in the box.
People are hunting down this bug right now.
Please let me know whether using a new Nokia battery, or charging with  
an external charger helps you.

On Jun 18, 2008, at 9:13 AM, steve wrote:

> Ah ok.
> Well  I had two Neos GtA02 # 86 and I think #72.
> I checked them both out when I got them and they both worked fine,  
> made
> calls functioned properly.
> After testing for a couple days I turned both phones off.
> Then I had a customer who needed a phone for his engineers so I  
> figured,
> I'll give him one of mine.
> So I went to charge it. USB laptop. No charge. Next day I try factory
> charger #1, wall socket. No charge
> Switch wall sockets. No charge. Switch to razr charger ( 850ma) no  
> charge.
> No nothing. I reseat the battery
> Try factory charger #2. nuthing.  So, I just sent it to the customer  
> and
> figured I will dump the
> Problem in michaels lap ( some friend steve)
> So, phone number #86. same thing. I have an old GTA01 battery that I  
> can
> try, or I can go get a
> Nokia battery. I also Have a car charger I could try.
> -----Original Message-----
> From: Joerg Reisenweber [mailto:joerg at]
> Sent: Monday, June 16, 2008 3:17 AM
> To: openmoko-kernel at
> Cc: steve; 'Wolfgang Spraul'
> Subject: Re: My Gta02s wont charge
> Am Mo  16. Juni 2008 schrieb steve:
>> Help.
> Please a little more detail!
> What's happening, what are the steps you took and the reaction of the
> device.
> Where start tings to differ from what you'd expect?
> We have to make sure your power outlet is working first ;-) Honestly:
> charger defect? Neo defect? Charger detection? Battery?
> We need more details.
> cheers

More information about the openmoko-kernel mailing list