My Gta02s wont charge

Sean McNeil sean at
Fri Jun 20 20:17:22 CEST 2008

Yes, I can run off usb without the a battery. But if I have a drained 
battery, I cannot. Seems like charging pulls too much power so I cannot 
run.What I had to do at one time was pull battery and charger out. Hold 
down the aux key. Put battery in. Put usb in. hold down the power key. 
release aux key. wait for menu. When I did this the battery starts to 

steve wrote:
> Na, mine wont run off USB power. I'll double check on a 2nd computer.
> My unit is pre production, but I know guys have done battery drain tests
> With no problems. So, scratches head....
> I tried with the battery in, battery out.  Sean, can you run yours while
> plugged into usb with the battery removed?
> You have a phone from the same batch I have. 
> -----Original Message-----
> From: Werner Almesberger [mailto:werner at] 
> Sent: Wednesday, June 18, 2008 6:24 PM
> To: Sean McNeil
> Cc: steve; openmoko-kernel at
> Subject: Re: My Gta02s wont charge
> Sean McNeil wrote:
>> You do not need a battery to run the phone. It will run off USB power.
> Some do, some don't. E.g., I never got any GTA02 (out of 1-2 samples) to run
> from USB power for more than a few seconds.
> Regarding charging, the big issue seems to be that we turn off the charger
> if we don't have USB power. The PMU remembers that setting while it has any
> power at all. Thus, if the battery is empty and the charger happens to be
> turned off, USB power is simply ignored.
> So far the theory. I've tried to actually confirm that behaviour (so that I
> could observe an improvement after changing the logic), but only got more or
> less random results, with the system occasionally not charging when it
> should, and (quite often) happily powering up when I didn't expect it to :-(
> So there seems to be more going on than meets the eye.
> - Werner

More information about the openmoko-kernel mailing list