Can't get bluetooth started

Sean McNeil sean at
Fri May 30 21:08:16 CEST 2008

I'm not sure why, but I can't get the bluetooth device to start on 
GTA02v6 with andy kernel:

<6>usbcore: registered new interface driver usbfs
<6>usbcore: registered new interface driver hub
<6>usbcore: registered new device driver usb
<6>Bluetooth: Core ver 2.11
<6>NET: Registered protocol family 31
<6>Bluetooth: HCI device and connection manager initialized
<6>Bluetooth: HCI socket layer initialized
<7>ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver
<6>s3c2410-ohci s3c2410-ohci: S3C24XX OHCI
<6>s3c2410-ohci s3c2410-ohci: new USB bus registered, assigned bus number 1
<6>s3c2410-ohci s3c2410-ohci: irq 42, io mem 0x49000000
<6>usb usb1: configuration #1 chosen from 1 choice
<6>hub 1-0:1.0: USB hub found
<6>hub 1-0:1.0: 2 ports detected
<6>usbcore: registered new interface driver berry_charge
<3>s3c2410_udc: debugfs dir creation failed -19
<6>s3c2440-usbgadget s3c2440-usbgadget: S3C2440: increasing FIFO to 128 
<4>ether gadget: using random self ethernet address
<4>ether gadget: using random host ethernet address
<6>usb0: Ethernet Gadget, version: May Day 2005
<6>usb0: using s3c2410_udc, OUT ep2-bulk IN ep1-bulk STATUS ep3-bulk
<6>usb0: MAC ba:53:87:a2:2b:75
<6>usb0: HOST MAC da:df:99:64:2c:0b
<6>usb0: full speed config #1: 500 mA, Ethernet Gadget, using CDC Ethernet

usb gadget is working. I am nfs mounting filesystem over usb.

echo "1"> /sys/bus/platform/devices/neo1973-pm-bt.0/power_on
cat /sys/bus/platform/devices/neo1973-pm-bt.0/power_on

It says:

neo1973-pm-bt neo1973-pm-bt.0: GTA02 Set PCF50633 LDO4 = 3200

device never comes up. Can't I have a usb gadget and use bluetooth? I 
thought so. It would really be bad if I can't.

More information about the openmoko-kernel mailing list