stable-tracking problems

Werner Almesberger werner at
Sun Nov 2 22:48:46 CET 2008

Hi Andy,

after pulling the latest stable-tracking, I hit a lot of weird

First of all, it seems that the Atheros WLAN+SDIO stack is broken.
There's no indication that the device is even probed. Oddly enough,
if I add my Linux SDIO patches, my driver works, so this doesn't
seem to be the reset problem coming back from the dead.

More confusingly, only the last two revisions
(b961c6de2a96a96436bb342722974aaf54aea638 and
9092e89f3f8bfabb1bb892da4f5c85fce8ed9144) even compile.

All the earlier ones I tried to build fail - many of them with
missing includes in mach-gta02.c. This happens even if I go back
to commits of which I'm pretty sure that they built not too long

Furthermore, the dates look wrong. E.g., ar6k-essid-one-and-32.patch
was added around September 16, but commit
d41035e9ef253ddd2e9d2c59b550fdfab1719d0a says November 1.

What I did was

git checkout master
git pull
git checkout origin/stable-tracking

Is this (still) the correct sequence ?

I've tried origin/andy-tracking but it doesn't build either.
origin/stable does build and even the Atheros WLAN+SDIO stack works.

I'm now pulling the whole repository anew to see if the problem is
on my side, but this will take a few hours ...

- Werner

More information about the openmoko-kernel mailing list